Back to overview
Resolved
API is unavailable
Oct 20, 2025 at 9:24am UTC
Affected services
Callshift Dashboard (app.callshift.ai)
Resolved
Oct 20, 2025 at 9:24am UTC
Callshift API is currently unavailable due to AWS global outage.
No calls can be passed or received on the platform.
Affected services