Back to overview
Resolved

Degraded call availability due to third-party infrastructure issue

Apr 15, 2026 at 8:15am UTC
Affected services
Callshift Dashboard (app.callshift.ai)

Resolved
Apr 15, 2026 at 8:15am UTC

Apr 15, 2026 — 12:15 PM UTC — Investigating

We identified that approximately 25% of incoming calls were failing to start. The issue was traced to delays in our event processing pipeline caused by a degradation at our infrastructure provider Inngest.

Apr 15, 2026 — ~6:36 PM UTC — Partial recovery Call start reliability began improving as our provider resolved the primary function scheduling delays. Some residual latency remained.

Apr 15, 2026 — 11:21 PM UTC — Resolved

Full service restored. Our provider confirmed complete resolution of the underlying infrastructure issue. All calls are processing normally.